Unknown certificate creator error

Installed a fresh letsencrypt cert for my website. Worked great for ubuntu 20.04 LTS for a week. When I upgraded this to ubuntu 20.04.01 LTS (AWS), this happened and also pipenv broke.

Tried these steps already:

  • Renewal
  • Deleting the cert and generation of new cert
  • Re-installation of certbot

None worked. Any help would be appreciated :slight_smile:

This is a known bug in v22.9 and will be solved shortly when I get the patch release out. Will update you (hopefully today) when that happens.

You always help me out. Thank you :slight_smile:

1 Like

Did you try with 22.9.1? Please LMK how it goes.

Sorry for the late reply. Using Sanic 22.9.1. No issues persist.

I deleted my server with backup and re-initiated with the latest image i.e UBUNTU 22.04.01 LTS. Everything is working fine now.

When I upgraded the ubuntu from 22.04 to 22.04.01, I faced those issues. Now, none. Don’t know what fixed these. Upgrading Sanic or re-initiating server.

#correction (not ubuntu 20.04 as said In first post, I’m using 22.04)

1 Like

Nice! Thanks for the update.