Allow later websockets release for Sanic 20.x.x (Python 3.6)

Currently, Sanic 20.12.4 requires websockets<9.0,>=8.1. Websockets pushed out version 9.0 (Changelog - websockets 10.2.dev4+g668f320.dirty documentation) to address a security vulnerability. Can you change the requirement for websockets to <=9.1, >=8.1? Thanks!

1 Like

Hi @nickt1512 thanks for bringing this to our attention - we’ll get this taken care of as quickly as we can.

Thanks, @sjsadowski , for the quick response.